Canvas-guider (Swedish)Canvas-guiderGrundläggande Handledning Guide Allmän informationVilka krav ställer Instructure-produkter på webbläsare och datorer?

Vilka krav ställer Instructure-produkter på webbläsare och datorer?

För bästa prestanda bör du använda Instructure-produkter i den senaste eller i någon av de närmast föregående fullversionerna av Chrome, Firefox, Edge eller Safari. Eftersom Instructure-produkter är byggda med webbstandarder kan Instructure-produkter användas på Windows, Mac, Linux, iOS, Android, eller vilken annan enhet som helst som har en modern webbläsare.

För att köra Instructure-produkter krävs att du använder de senaste kompatibla webbläsarversionerna. Du bör hålla ditt operativsystem uppdaterat med de senaste säkerhetsuppdateringarna och -uppgraderingarna.

Obs! Användare av URL för Vanity Canvas kan stöta på problem med SSL-validering om deras webbläsare eller andra verktyg interagerar med Canvas inte är kompatibla med SNI (Server Name Indication). Alla webbläsarversioner i den här guiden är SNI-kompatibla.

Webbläsare som stöds

Instructure-produkter stödjer den senaste och de närmast föregående fullversionerna av följande webbläsare:

  • Chrome 101 och 102
  • Firefox 100 och 101 (utökade versioner stöds inte*)
  • Edge 101 och 102
  • Respondus Lockdown Browser (med stöd för de senaste systemkraven)
  • Safari 14 och 15 (endast Macintosh)

Du kan bekräfta att webbläsaren du har är uppdaterad genom att använda webbläsarkontrollverktyget i steget nedan.

Du bör alltid använda den senaste versionen av din föredragna webbläsare. Din webbläsare kommer att meddela dig när en ny version är tillgänglig.

Obs! Safari 13.1 och senare versioner innehåller en uppdatering som kan orsaka problem vid nedladdning av filer, visning av bilder och chattaviseringar i Canvas. Canvas-teknikerna arbetar för närvarande på en lösning för det här problemet. Under tiden kan du undvika problem med filer, bilder och aviseringar genom att inaktivera förhindrande av spårning mellan webbplatser i Safari när du använder Canvas. Om inaktivering av förhindrande av spårning mellan webbplatser inte löser problemen kan du testa en annan webbläsare som stöds.

Banner i Canvas för webbläsare som inte stöds

Vissa webbläsare som stöds kan fortfarande producera en banderoll med texten Din webbläsare uppfyller inte minimikraven för Canvas. Om du har uppgraderat din webbläsare men du fortfarande ser varningen, prova att logga ut från Canvas och rensa dina cookies ifrån din webbläsare.

Utökade webbläsarversioner för företag i Canvas

Chrome och Firefox erbjuder utökade versioner för företag (ESR:er) som hanterar klientdatorer. Chrome ESR kan uppdateras med den befintliga fullständiga versionen när som helst. Men Firefox ESR uppdateras endast för var sjunde större version, vilket gör att Firefox ESR överlappar med utdaterade versioner. På Firefox ESR-webbsidan står det att support på ESR-versionen kanske inte erbjuds för alla webbapplikationer på grund av att den här versionen har försenats. Institutioner som använder Firefox ESR bör överväga att distribuera den senaste versionen för att få den bästa Canvas-upplevelsen.

* Varningsbannern för ESR-versioner gäller fortfarande och visas i Canvas i alla webbläsarversioner under minimikravet.

Kända webbläsarbeteenden

Liksom alla Instructure-produktfunktioner, prioriteras webbläsare med motsatt beteende av våra produktteam, och visa beteenden från tidigare versioner kanske inte är lösta. Om det finns ett beteende i den tidigare versionen av webbläsaren som inte existerar i den nuvarande versionen, är den bästa lösningen att uppdatera till den senaste versionen av webbläsaren.

Tillgänglighet

Instructure engagerar sig för W3C:s webbtillgänglighetsinitiativ. Du kan läsa mer om skärmläsare som stöds och webbläsarkombinationer i dokumentenCanvas-tillgänglighetsstandarder, tillgänglighet inom Studio, och Mastery Connect-tillgänglighetsalternativ.

JavaScript

JavaScript måste vara aktiverat för att köra Canvas.

Plugins och tillägg för webbläsare

Vissa webbläsarplugins eller tillägg kan orsaka konflikt med Instructure och påverka funktionaliteten. Om du upplever ett beteende som inte tillåter dig att titta på eller delta i Instructure-produkter, se till att du har inaktiverat tillägg eller plugins som interagerar med din webbläsare.

För felsökning, överväg att logga in på Instructure-produkter med hjälp av ett inkognito- eller privat webbläsarfönster vilket ger en webbläsarsession utan föregående sök- eller surfhistorik, med cookies i webbläsaren eller andra faktorer som kan störa webbläsaren. Om du har möjlighet att se och delta i en Instructure-produkt med hjälp av ett inkognito- eller privat webbläsarfönster, är beteendet du upplever sannolikt relaterade till webbläsaren och inte Instructure-produkten.

Webbläsarens Integritetsinställningar

Vi rekommenderar att du följer alla säkerhetspolicyer för webbläsare som fastställts av din institution, speciellt om du använder Instructure-produkter på en dator som ditt lärosäte har tillhandahållit.

När innehåll visas anpassar sig Instructure-produkter som standard till webbbläsarens inställningar. Vissa webbläsare kan ibland göra ändringar i sina integritetsinställningar för att skydda användare från potentiellt oskyddat innehåll. Oskyddat innehåll identifieras med prefixet http: // i webbadressen och kan skapa blandat innehåll på din produktsida. Säkert innehåll identifieras med https: // prefix i webbadressen. För bästa användarupplevelse bör innehållet vara säkert för att undvika webbläsarkonflikter.

  • Om du är en Canvas-administratör kan osäker innehåll orsakas av att vara värd för en osäker JS/CSS-fil utanför Canvas. Om anpassade uppladdningar stöds för ditt konto kan du vara värd för din fil i Canvas Theme Editor, som löser eventuella webbläsarkonflikter.
  • Om du är en Canvas instruktör som bäddar in Canvas lektioner i din kurs kan du förhindra webbläsarproblem med blandat innehåll med hjälp av Canvas Guides URL:er. 

Kända webbläsarbeteenden

Chrome, Edge, Firefox och Safari använder HTML5 för att visa webbinnehåll, vilket ger en snabbare och säkrare webbupplevelse. För bästa prestanda för Instructure-produkter bör innehåll designas med stöd för HTML5.

I webbläsare som Safari visas aldrig osäkert innehåll i webbläsaren.

Men i Chrome och Firefox har du alternativet att visa osäkert innehåll. Var uppmärksam på restriktioner och var försiktig när du väljer att visa osäkert innehåll.

Chrome Säkerhet

Chrome Säkerhet

Google Chrome kontrollerar att det innehåll du granskar ifrån webbplatsen överförs säkert. Om du besöker en sida i din Instructure-produkt som är kopplad till osäkert innehåll, kommer Chrome att visa en sköldikon i webbläsarens adressfält [1] .

Du kan välja att åsidosätta säkerhetsbegränsningen och visa innehållet ändå genom att klicka på skärmikonen och sedan klicka på Ladda osäkra skript (Load unsafe script) knappen [2].

Chrome-behörigheter för mediefiler

Chrome-behörigheter för mediefiler

Chrome har en egen behörighet för mediefiler i webbläsaren. Om du vill använda din dators kamera och mikrofon med Instructure-produkter ska du tillåta åtkomst till Instructure-produkter via Chromes behörighetsinställningar för mediefiler. Den här prompten visas precis nedanför adressfältet [1]. Tillåt åtkomst genom att klicka på knappen Tillåt (Allow) [2].

Firefox säkerhet

Firefox säkerhet

Firefox kontrollerar att det innehåll du granskar ifrån webbplatsen överförs säkert. Om du besöker en sida i din Instructure produkt som är kopplad till osäkert innehåll, kommer Firefox att visa ett lås med en varningsikon i webbläsarens adressfält [1].

Du kan välja att åsidosätta säkerhetsbegränsningen och visa innehållet ändå genom att klicka på låset med en varnings-ikon och klicka på pilen för att expandera dina alternativ [2], och välj Inaktivera skydd för tillfället (Disable Protection for now) alternativet [3].

Datorspecifikationer

För bästa prestanda bör du ansluta till Instructure-produkter med en dator som har stöd för de senaste webbläsarversionerna. Du rekommenderas att använda en dator som är högst fem år gammal och som har minst 1 GB RAM-minne.

Operativsystem

Instructure-produkter kräver att du använder de senaste kompatibla webbläsarversionerna. Du bör hålla ditt operativsystem uppdaterat med de senaste säkerhetsuppdateringarna och -uppgraderingarna.

Internethastighet

Instructure-produkter har, tillsammans med kompatibilitet och webbstandarder, noggrant tagits fram för att fungera i miljöer med låg bandbredd.

Du rekommenderas att använda en internetuppkoppling på minst 512 k/bit.

Mobila enheter

Instructure-produkter har optimerats för visning på datorskärmar. Men om du använder en mobil enhet kan du ansluta till Instructure-produkter med en mobilapp eller mobil webbläsare. 

Mobilappar

För bästa användarupplevelse, ladda ner mobilapparna för produkten. Mobilappar finns för närvarande tillgängliga för Canvas och Mastery Connect.

Canvas-mobilappar kräver Android 8.0 eller senare och iOS 14.0 eller senare. Canvas har ett begränsat stöd för inbyggda mobila webbläsare på surfplattor. För ytterligare information, hänvisa till begränsad-support för mobila webbläsare.

Mastery Connect-mobilappar kräver Android 6.0 eller senare och iOS 13.0 eller senare. Ytterliggare information finns i Krav för Mastery Connect (Mastery Connect Requirements).

Mobil-webbläsare

Besök Apple Store eller Play Store för att ladda ner mobila webbläsare. Följande stora webbläsare är kompatibla med mobila enheter:

iOS

  • Safari (standardwebbläsare med begränsad Canvas-support)
  • Chrome

Android

  • Chrome (standardwebbläsare med begränsad support för Canvas)*
  • Internet
  • Firefox

*Standardwebbläsaren i Android varierar per mobilenhet.